Active Topics


Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Gear speed sensor problem - Fault code 25  (Read 672 times)

0 Members and 1 Guest are viewing this topic.

Offline KGC

  • SX Junior
  • *
  • Topic Author
  • Posts: 12
  • Country: UK
Gear speed sensor problem - Fault code 25
« on: June 22, 2019, 05:12:00 PM »
Hi all, has anybody suffered a Fault code 25, with the Engine management light illuminated and a flashing symbol -/- instead of the gear indication on the LCD display? Walmsleyr, me and another guy, I met today at Chris Walkers in Grantham, have had the same issue. At least two of us have an extra tooth on the front sprocket, which  ay or may not be the reason for it. Other guys with non- factory sprocket combos please advise. I want to know if there is a recall or replacement part required, other than simply self-clearing the fault or taking it to the dealer, who is going to ask Kawasaki UK about the issue.

Offline Scotty001

  • SX God
  • *****
  • Posts: 1006
  • Bike: 17 Z1000sx
  • City / Town: Hampshire
  • Country: UK
Re: Gear speed sensor problem - Fault code 25
« Reply #1 on: June 22, 2019, 05:38:50 PM »
I think recall some issues and posts saying you can't change the front sprocket size on these bikes but the rear is fine., if you do a search you will come across the posts I can't recall if or what error codes it threw up when people tried to change the front sprocket size

Online KD

  • SX God
  • *****
  • Posts: 2701
  • Bike: 2018 Z1000SX WJF
  • City / Town: Warminster
  • Country: Wiltshire, Uk
Re: Gear speed sensor problem - Fault code 25
« Reply #2 on: June 22, 2019, 06:27:58 PM »
As Scotty stated ... That's your issue. I forget how many times its been stated since 2017 ...

Put the front sprocket back to standard and get the ecu reset by Kwaka. I find that changing the rear down to a 39T works well.
Regards David.

2018 Kawasaki Z1000SX WJF.
2018 Triumph Tiger 1200 XRT.

Offline KGC

  • SX Junior
  • *
  • Topic Author
  • Posts: 12
  • Country: UK
Re: Gear speed sensor problem - Fault code 25
« Reply #3 on: June 22, 2019, 08:23:44 PM »
Thank you for the replies, I will go back to Chrus Walker with them. 

Offline KGC

  • SX Junior
  • *
  • Topic Author
  • Posts: 12
  • Country: UK
Re: Gear speed sensor problem - Fault code 25
« Reply #4 on: June 22, 2019, 08:26:57 PM »
*Originally Posted by KD [+]
As Scotty stated ... That's your issue. I forget how many times its been stated since 2017 ...

Put the front sprocket back to standard and get the ecu reset by Kwaka. I find that changing the rear down to a 39T works well.

No doubt this is the answer, I wonder why it takes so many miles and time to show the error.

Offline kernowjim1

  • SX Pro
  • ***
  • Posts: 184
  • Bike: 2018 Z1000SX
  • City / Town: Torpoint
  • Country: UK
Re: Gear speed sensor problem - Fault code 25
« Reply #5 on: June 23, 2019, 05:33:21 PM »
*Originally Posted by KGC [+]
No doubt this is the answer, I wonder why it takes so many miles and time to show the error.

The ECU makes calculations between what it thinks the speed of the rear wheel should be based on programmed parameters based on the actual speed of the wheel - I expect there are tiny variables that are allowed (such as 2 teeth down on the rear sprocket or a 55 profile rear tyre) but consistent incorrect calculations will eventually result in the error code

Offline keithzx

  • SX Master
  • ****
  • Posts: 307
  • Bike: z 1000 sx tourer
  • City / Town: south shields
  • Country: uk
Re: Gear speed sensor problem - Fault code 25
« Reply #6 on: June 23, 2019, 07:17:14 PM »
is the fault not electrical , does the sx gear indicator not work on voltage variations ???

  some information on you tube regarding Kawasaki  fault code  25     don't know if it helps with the sx

Offline DB1974

  • SX Junior
  • *
  • Posts: 1
  • Country: UK
Re: Gear speed sensor problem - Fault code 25
« Reply #7 on: June 27, 2019, 01:06:01 PM »
I'm the other guy from CWK at the weekend. I have had this issue twice and both times it has cleared itself.

+1 tooth on the front & a 55 section rear tyre

DB

Offline HeavyRain

  • SX Member
  • **
  • Posts: 52
  • Bike: Z1000SX
  • City / Town: Swindon
  • Country: UK
Re: Gear speed sensor problem - Fault code 25
« Reply #8 on: June 28, 2019, 10:27:55 AM »
If the ECU uses EngineRPM / WheelRPM to determine the current gear, rather than a gear position sensor, then the the ~7% change of dropping a front sprocket tooth could well put that measurement ouside expected boundaries.

It's quite reasonable for the ECU to generate a fault, as the rear wheel sensor is involved in safetry-critical (and legislative) systems. Without full access to the software, I doubt there's a lot that can be done, other than by Kawasaki's ECU OEM.

Offline AlbaKawa

  • SX Member
  • **
  • Posts: 30
  • Bike: ZSX/YZF/CBR/X7
  • City / Town: Clydebank
  • Country: Scotland
Re: Gear speed sensor problem - Fault code 25
« Reply #9 on: July 01, 2019, 11:04:34 PM »
I've got the code 25 on mine, but standard size tyres and standard gearing. Happened 2 weeks out of warranty but it's going in on Thursday to see if  Kawasaki will cover it as a "courtesy" repair.

 


expletive